Forum Wiki Galerie Kontakt Wie man Fragen richtig stellt. Tutorial Forum
Zurück   GIMP-Forum 3.0 > Probleme > Archiv > Technische Fragen

Hinweise
Alt 10.02.2010, 15:08   #1
Rupi
Neuer Benutzer
 
Registriert seit: 10.02.2010
Beiträge: 4
Ausrufezeichen Win7 64: gtk+ und python

Hallo!

Ich bin gerade dabei mir gimp 2.6.8 nebst Python u.s.w. für die Erweiterungen zu installieren.
Die Dateien und die Reihenfolge der Installation soll folgende sein, wie ich es auf gimp.org nachlesen konnte:

gtk+-bundle_2.16.6-20090912_win64.zip
python-2.6.4.amd64.msi
pycairo-1.8.6.win32-py2.6.exe
pygobject-2.20.0.win32-py2.6.exe
pygtk-2.16.0+glade.win32-py2.6.exe
gimp-2.6.8-i686-setup.exe

Wie man sehen kann, handelt es sich bei gtk+ und python um die 64bit Varianten. Diese ließen sich auch problemlos installieren und laufen. Nun meckert aber pycairo bei der Installation: python konnte nicht gefunden werden.

Frage: ist das ein Problem von Win7 (64bit) oder eher ein Problem mit der 64bit Variante von python64 und/oder gtk+64? Muss ich die 32bit-Variante von python (und/oder gtk+) installieren um den ganzen Krempel zum Laufen zu bekommen?

Vielen Dank für Eure Aufmerksamkeit
Rupi ist offline  
Alt 11.02.2010, 14:29   #2
houz
Erfahrener Benutzer
 
Benutzerbild von houz
 
Registriert seit: 26.12.2006
Ort: Saargebiet
Beiträge: 3.718
Standard

Ich dachte, dass GIMP unter Windows sein eigenes GTK mitbringt. Ist das bei 64 Bit anders?
houz ist offline  
Alt 11.02.2010, 19:30   #3
Rupi
Neuer Benutzer
 
Registriert seit: 10.02.2010
Beiträge: 4
Standard

Zitat:
Zitat von houz Beitrag anzeigen
Ich dachte, dass GIMP unter Windows sein eigenes GTK mitbringt. Ist das bei 64 Bit anders?
Das ist auch so. Allerdings muss man gtk+ etc VOR Gimp installieren, wenn man die ganzen Filter (AddOns) nutzen will, die man nachträglich installieren kann.
Rupi ist offline  
Alt 11.02.2010, 20:04   #4
houz
Erfahrener Benutzer
 
Benutzerbild von houz
 
Registriert seit: 26.12.2006
Ort: Saargebiet
Beiträge: 3.718
Standard

Kann es sein, dass du da gerade was mit Python verwechselt? Das muss vor GIMP installiert sein, damit man es in GIMP nutzen kann. GTK muss man nicht mehr gesondert installieren. Im besten Fall ist das überflüssig, im schlechtesten schädlich.
houz ist offline  
Alt 11.02.2010, 22:49   #5
schumaml
Erfahrener Benutzer
 
Benutzerbild von schumaml
 
Registriert seit: 21.01.2004
Ort: Leinfelden
Beiträge: 6.759
Standard

Zitat:
Zitat von Rupi Beitrag anzeigen
Allerdings muss man gtk+ etc VOR Gimp installieren, wenn man die ganzen Filter (AddOns) nutzen will, die man nachträglich installieren kann.
Ich habe den Autor der Anleitung, der du vermutlich gefolgt bist (registry.gimp.org?) schon mehrfach darauf hingewiesen, dass das entweder falsch ist oder mir bitte das Gegenteil bewiesen werden soll.
schumaml ist offline  
Alt 12.02.2010, 02:16   #6
silvio
Erfahrener Benutzer
 
Registriert seit: 18.05.2004
Ort: Germania Superior
Beiträge: 1.904
Standard

Zitat:
Zitat von houz Beitrag anzeigen
Kann es sein, dass du da gerade was mit Python verwechselt? Das muss vor GIMP installiert sein, damit man es in GIMP nutzen kann. GTK muss man nicht mehr gesondert installieren.
...,

das war auch mein Wissensstand.
Zuerst Python (damit Gimp dieses bei der Installation vorfindet) und anschließend Gimp mitsamt GTK
Zumindest war es so mal auf Deviant beschrieben worden. Ist aber schon eine Weile her.
__________________
Gruß, Silvio

Antergos Linux | Manjaro Linux | Windows 10 | GIMP 2.10.10 | Darktable 2.6
silvio ist offline  
Alt 12.02.2010, 11:09   #7
Rupi
Neuer Benutzer
 
Registriert seit: 10.02.2010
Beiträge: 4
Standard

Sodele.
Es war ein Problem mit Python64. Nach dem Entfernen von dieser 64bit-Version und der Installation von Python32 ließ sich der Rest problemlos installieren.

@schumaml
Also ich habe jetzt die Installation so vorgenommen, wie in meinem Startpost beschrieben (lediglich Python32 statt 64). Bei der Installation von Gimp habe ich die Option gtk+ abgewählt, da ich das ja schon installiert habe. Alles ist prima
Rupi ist offline  
Alt 12.02.2010, 11:48   #8
silvio
Erfahrener Benutzer
 
Registriert seit: 18.05.2004
Ort: Germania Superior
Beiträge: 1.904
Standard

Zitat:
Zitat von Rupi Beitrag anzeigen
Nach dem Entfernen von dieser 64bit-Version und der Installation von Python32 ließ sich der Rest problemlos installieren.
...,

achsooo, dann hattest du anscheinend Gimp in 32 und Python 64bit. Na das konnte ja nicht harmonieren.
__________________
Gruß, Silvio

Antergos Linux | Manjaro Linux | Windows 10 | GIMP 2.10.10 | Darktable 2.6
silvio ist offline  
Alt 12.02.2010, 12:09   #9
schumaml
Erfahrener Benutzer
 
Benutzerbild von schumaml
 
Registriert seit: 21.01.2004
Ort: Leinfelden
Beiträge: 6.759
Standard

Zitat:
Zitat von Rupi Beitrag anzeigen
Also ich habe jetzt die Installation so vorgenommen, wie in meinem Startpost beschrieben (lediglich Python32 statt 64). Bei der Installation von Gimp habe ich die Option gtk+ abgewählt, da ich das ja schon installiert habe. Alles ist prima
Was passiert denn ohne gtk+-bundle, aber dafür mit dem GTK+ von GIMP?

Geändert von schumaml (27.03.2010 um 21:11 Uhr)
schumaml ist offline  
Alt 26.03.2010, 21:02   #10
Rupi
Neuer Benutzer
 
Registriert seit: 10.02.2010
Beiträge: 4
Standard

Zitat:
Zitat von schumaml Beitrag anzeigen
Was passiert denn ohne gtk+-bundle, aber dafür mit dem GK+ von GIMP?
Nichts, vermutlich. Aber so weiß ich, wann ich was installiert habe. Nebenbei habe ich begriffen, was ich da eigentlich tue und so weiter.

Womit ich hiermit meinen Dank ausspreche
Rupi ist offline  
 

Lesezeichen

Stichworte
gtk+ , pycairo , pygobject , pygtk , python

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist Aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Plugins in Python - und zwar richtig schumaml Plug-ins 26 11.05.2019 09:44
[MeetTheGIMP] - Episode 129: Octave Sharpening Python Plugin Wilber GIMP 0 12.12.2009 19:00
Python Fu und Script Fu ...?! PKHG Skripte 0 20.02.2009 15:19
GIMP Plugins/Scripts in Python schreiben MichaJo OFF-Topic 2 18.01.2008 12:20


Alle Zeitangaben in WEZ +2. Es ist jetzt 09:57 Uhr.


Powered by vBulletin® Version 3.8.2 (Deutsch)
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.