Forum Wiki Galerie Kontakt Wie man Fragen richtig stellt. Tutorial Forum
Zurück   GIMP-Forum 3.0 > Probleme > Technische Fragen

Hinweise
Alt 05.12.2017, 11:05   #1
malthea
Benutzer
 
Benutzerbild von malthea
 
Registriert seit: 14.04.2006
Beiträge: 60
Standard gimp 2.8.22 startet extrem verlangsamt

Guten Morgen,

ich habe vor ein paar Wochen den neuesten gimp installiert und musste feststellen, dass sich der Programmstart extrem verlängert hat - ich schätze, dass es mehr als fünfmal so lange wie vorher dauert, bis alles geladen ist. Ich habe weder viele Schriften und kaum extra PIs auf dem Rechner und seit der vorherigen gimpversion ist da von meiner Seite aus nichts dazu gekommen. Auch das Beenden erfolgt unsauber, die abgedockten Werkzeugfenster schließen sich erst eine Zeit später. BS ist win8.
Gibt es eine Möglichkeit, das zu umgehen?

Grüße Malthea
malthea ist offline   Mit Zitat antworten
Alt 05.12.2017, 17:45   #2
Asmodis
Erfahrener Benutzer
 
Benutzerbild von Asmodis
 
Registriert seit: 25.05.2009
Ort: Karlsruhe
Beiträge: 1.088
Standard

Hallo Malthea, ja, das ist leider ein Bug der in Gimp Version 2.8.22 mitgelieferten Bibliothek "fontconfig". Die verträgt sich wohl nicht mit den cache-Dateien, die vorige Versionen dieser Bibliothek angelegt haben und verschluckt sich daran. Anstatt den alten Cache nun jedoch einfach zu löschen und einmal neu anzulegen, wird durch den Bug jedes Mal ein neuer Cache angelegt - und das kann lange dauern.

Der Workaround ist recht einfach: Suche im Ordner C:\Users\DeinBenutzerName\AppData\Local nach einem Ordner mit dem Namen "fontconfig" und öffne diesen. Darin müsste sich ein Ordner mit dem Namen "cache" befinden. Diesen löschst du nun und startest gimp einmal neu, damit ein neuer Cache angelegt wird. Von nun an müsste Gimp wieder so schnell wie gewohnt (bzw. eventuell sogar ein bisschen schneller) starten.

Der Bug ist den Entwicklern bereits bekannt und wird mit dem nächsten Update behoben, soweit ich weiß.

Edit: Für alle, die eventuell über diesen Beitrag stolpern: Wie schumaml im entsprechenden Bugreport schreibt, kann dieser Bug durch gleichzeitiges Benutzen einer Entwicklerversion von Gimp immer wieder ausgelöst werden - wer also eine 2.9er Version von Gimp nutzt, sollte also immer wie oben beschrieben den fontcache löschen, bevor er auf die 2.8.22 zurückwechselt.
__________________
Lg, Simon
GIMP 2.8.22 / 2.9.6(dev) | Windows 10 (64Bit)

Downloads:
---> Gimp | G'MIC | Plugin-Registry <---

Gimp-Einstellungsordner: C:\Users\USERNAME\.gimp-2.8\

Asmodis ist offline   Mit Zitat antworten
Alt 06.12.2017, 14:00   #3
malthea
Benutzer
 
Benutzerbild von malthea
 
Registriert seit: 14.04.2006
Beiträge: 60
Standard

Vielen Dank für die schnelle Antwort!

Ich habe den cache-Ordner gelöscht und der Programmstart wurde deutlich beschleunigt, auch das Beenden ist jetzt so, wie es sein soll.
malthea ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist Aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Gimp startet nicht mehr, Fehlermeldung gimp1001 Technische Fragen 7 08.04.2015 14:09
Gimp besorgen und installieren. Rebell Technische Fragen 106 28.10.2014 18:30
Gimp 2.8.14 startet nicht mehr nach UFRAW 0.19.2-2 transwarp2010 Technische Fragen 7 21.10.2014 09:11


Alle Zeitangaben in WEZ +2. Es ist jetzt 19:24 Uhr.


Powered by vBulletin® Version 3.8.2 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.