PDA

Vollständige Version anzeigen : Brush Manager


Renderer
07.08.2006, 11:31
Hier (http://spbogie.dajoob.com/brushmanager/gimpbrushmanager.html) gibts ein Script, mit dem man aus Gimp heraus seine Brushsets wechseln kann.
Finde ich ja super nützlich, gibts aber leider nicht für Windows. :sad:
Hab ich im Gimp-Talk Forum gefunden.

MfG
Renderer

lupus
07.08.2006, 12:47
Danke Renderer,
sowas habe ich schon lange gesucht.
Das werde ich heute Abend gleich mal probiern. Denn eigentlich brauche ich für die Fotobearbeitung fast nur rund, meist unterschiedlich weiche Pinsel. Gut einen Eigenen Pinsel kann man verstellen, mal sehen wie es sich macht.

juergen

Ravetracer
07.08.2006, 12:51
Danke Renderer... hab' aber gerade gemerkt, dass ich mein Gimp nochmal neu kompilieren muss.
Habe die Python Unterstützung vergessen gehabt.

Aber wenigstens gibt's für Windows die PhymodMedia-Plugins... für Linuxsourcen geht der Link nicht :(

Renderer
07.08.2006, 12:59
Aber wenigstens gibt's für Windows die PhymodMedia-Plugins

Der Link scheint down zu sein. Was machen denn diese Plugins?

MfG
Renderer

Ravetracer
07.08.2006, 13:01
Das ist 'nen Natural-Plugin für reelle Wolken und Sonne.
Der Link für den Sourcecode ist down, aber bei Gimp-Talk gibt's noch 'nen Download für
Windows. Der geht und das File hab ich auch, nur brauchen kann ich's nicht.

http://www.gimptalk.com/forum/topic/Sky-amp-Clouds-Sun-100-Natural-Plugin-Download-21-1.html

schumaml
07.08.2006, 13:12
Falls jemand das
os.symlink(INSTALL_DIR+i+j,ACTIVE_DIR+j)
zu einem Kopieren oder Umbenennen umbaut, dann würde das Skript auch für Plattformen != Linux (eigentlich: Unix) funktionieren.

Ravetracer
07.08.2006, 13:18
Schumaml, bei mir geht das Plugin nicht. Du weist bestimmt mehr als ich.
Kannst du was aus diesem Fehler schließen?


>>> pdb.python_fu_brush_manager()
Traceback (most recent call last):
File "/usr/local/lib/gimp/2.0/plug-ins/gtkcons.py", line 262, in run
r = eval(cmd, self.namespace, self.namespace)
File "<string>", line 0, in ?
RuntimeError: execution error
/usr/local/lib/gimp/2.0/plug-ins/gtkcons.py:276: GtkDeprecationWarning: gtk.idle_add is deprecated, use gobject.idle_add instead
gtk.idle_add(self.scroll_bottom)


Habe GIMP 2.2.12 gerade neu mit Pythonunterstützung kompiliert.

lox2eagle
07.08.2006, 13:54
gtkcons.py:276: GtkDeprecationWarning: gtk.idle_add is deprecated, use gobject.idle_add instead
gtk.idle_add(self.scroll_bottom)Mal versucht, in Zeile 276 von gtkcons.py das gtk.idle_add durch gobject.idle_add zu ersetzten wie vorgeschlagen wird?

Ravetracer
07.08.2006, 15:24
Bringt keine Besserung, sondern nur mehr Fehler... mhh :???:
Ist ja auch nur 'ne Warning und kein Error. Der kommt ja schon vorher... ich schau mir das Script nochma genauer an.

Ravetracer
07.08.2006, 15:40
Geht jetzt.
Er mochte die ${HOME}-Variable nicht wirklich... hab' wieder zuviel an Bash gedacht ;)

Funktionieren tut's aber nicht wirklich. Wenn ich auf den OK-Button drücke, rührt sich nix.
Ich glaube aber, dass das an Python-Fu selbst liegt. In einem anderen Script tut sich beim OK-Button
auch nix. Aber was solls.

schumaml
07.08.2006, 16:27
Was heisst "tut sich nix"? Das Skript setzt ein paar symbolische Links um und bleibt möglicherweise mit Absicht offen. Falls es die Links nicht setzt, dann tut es nichts.

Ravetracer
07.08.2006, 16:37
Das ist ja nicht nur beim "Brushmanager" sondern auch beim "AquaButt2"-PlugIn. Bei beiden
rührt sich nix. Der Haken im Button blinkt kurz, aber das war's auch schon.

PieKey
03.11.2007, 01:12
Der Link ist leider mittlerweile down, würde sowas aber echt gerne in GIMP 2.4 haben!