PDA

Vollständige Version anzeigen : Problem von PSPI mit Umlaut im Usernamen


klausijoe
11.05.2016, 19:42
Hallo,

nach Verankerung der PSPI.exe im Plug-in-Verzeichnis von Gimp bekomme ich beim Start von Gimp 2.8.16 unter Windows 10 die Fehlermeldung "Could not open C:\Users\Jürgen\.gimp-2.8\pspirc.new for writing".
Das von mir ersehnte GML matting wurde dann zwar angezeigt, ließ sich aber nicht starten.

Nach einigen Google-Stunden und Vergleichsinstallation auf einem anderen PC konnte ich eingrenzen, dass das Problem offensichtlich der Umlaut im Users-Verzeichnis ist, denn diese gibt es auf dem anderen PC (der nicht meiner ist) nicht und ein Posting in einem anderen Forum zum selben Problem kam bezeichnenderweise von einem Günter (der leider nicht auf meine Anfrage geantwortet hat).

Ein Ändern des Benutzernamens im Windows wirkt sich leider nicht auf den USERS-Ordner aus, so dass dieser Lösungsweg mich nicht weiter gebracht hat.
Den betreffenden Ordner hart im Explorer zu ändern dürfte tiefgreifende Auswirkungen auf andere Anwendungen haben - wenn dies überhaupt ohne weiteres möglich ist.

Hat jemand mit dem gleichen Problem eine elegante Lösung gefunden, ohne in der Registry herumschrauben zu müssen, die pspi.exe zum Laufen zu überreden?

Vielen Dank im Voraus.
Jü:|rgen

Asmodis
11.05.2016, 22:02
Ja, das ist gar nicht mal schwierig: du kannst in Gimp unter Bearbeiten->Einstellungen->Ordner->Plugins beliebige weitere Ordner angeben, in denen nach Plugins gesucht werden soll. So kannst du für pspi zum Beispiel einfach einen Ordner direkt auf C: erstellen (oder halt sonstwo, wo es keine Umlaute im Pfad gibt) und diesen Ordner dann dort angeben. Wenn es wirklich am Ü lag, sollte es danach dann funktionieren :)

klausijoe
11.05.2016, 22:43
Erst mal vielen Dank für die schnelle Antwort.

Leider liegt dort nicht der Hund begraben, ich habe in den Ordner-Einstellungen bei sämtlichen Rubriken den Verweis auf den Nutzerpfad rausgelöscht und die Fehlermeldung bleibt.
Auch die Konfiguration von pspi zeigt nur auf den Programmpfad von Gimp.

Schön wär's gewesen - aber vielleicht gibt es noch andere Ideen...

Asmodis
11.05.2016, 23:27
ich habe in den Ordner-Einstellungen bei sämtlichen Rubriken den Verweis auf den Nutzerpfad rausgelöscht

Das war jetzt aber viel zu voreilig :D Die Pfade dort brauchst du durchaus noch, zum Beispiel wenn du eigene brushes oder Scripte nutzen willst...
Du solltest die Pfade da entweder wieder eintragen oder den Gimp-Benutzerordner komplett löschen/umbenennen, damit Gimp einen neuen mit der Standardkonfiguration anlegt.

Ich meinte nur, du sollst einen zusätzlichen Pfad angeben, also zum Beispiel C:\pspi oder ähnliches. Von löschen habe ich nie geredet. Bei genauerem Überlegen kann es aber tatsächlich sein, dass das nichtmal was bringen würde. Das sieht sehr danach aus, als würde pspi immer auf das Benutzerverzeichnis zugreifen, um dort einstellungsdateien abzulegen - egal wo das Plugin an sich liegt. In dem Fall hast du wohl nur die Option wirklich einen neuen Windows-Benutzer ohne Umlaute anzulegen (wäre btw. sowieso besser, Umaute und Leerzeichen gehören eigentlich überhaupt nicht in Ordnerpfade...)

Recht seltsam ist aber dennoch, dass immernoch eine Fehlermeldung auftaucht, obwohl du den Pfad zum Plugin ja anscheinend gelöscht hast!? Damit sollte Gimp das eigentlich nichtmal mehr beim Start laden... Steht denn in der Fehlermeldung auch noch das selbe drin? Und was steht in der Titelzeile der Meldung?

klausijoe
14.05.2016, 09:55
Hallo Simon,

endlich bin ich mal dazu gekommen, deinen Post zu verarbeiten.

Das Löschen des Gimp Benutzerordners hat auch nichts gebracht.

Du hast Recht, es war blöd von mir, zu glauben, jede Software käme inzwischen mit Umlauten zurecht. Nur habe ich keinen Bock, einen neuen Benutzer anzulegen - die Nummer habe ich unfreiwillig schon mal durch und da gibt es jede Menge Trist mit den Zugriffsberechtigungen.
Da werde ich wohl mal einen Registry-Hack veranstalten müssen und das doofe ü rausoperieren.

Hier kommt aber noch die Fehlermeldung zur Ansicht:
https://www.dropbox.com/s/xg34or6f0du09ah/gimp.png?dl=0
https://drive.google.com/file/d/0B1uMaatoKWiGZUhtd2xQZE9USmc/view?usp=sharing Verflixt, warum sind die Bilder nicht zu sehen?
Hier der Link zum freigegebenen Bild: https://drive.google.com/file/d/0B1uMaatoKWiGZUhtd2xQZE9USmc/view?usp=sharing

Das Problem liegt offensichtlich bei PSPI und nicht bei Gimp.

Ich warte mal noch etwas vor dem chirurgischen Eingriff in die Registry - vielleicht gibt es doch noch eine andere Lösung.

Trotzdem nochmal vielen Dank für die Bemühungen.

Ein schönes Pfingsten!
Jürgen